What’s Vulnerable › Vulnerabilities
CVE-2018-11796
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-09 · updated 2026-06-17
- Weakness: CWE-611
Description
In Apache Tika 1.19 (CVE-2018-11761), we added an entity expansion limit for XML parsing. However, Tika reuses SAXParsers and calls reset() after each parse, which, for Xerces2 parsers, as per the documentation, removes the user-specified SecurityManager and thus removes entity expansion limits after the first parse. Apache Tika versions from 0.1 to 1.19 are therefore still vulnerable to entity expansions which can lead to a denial of service attack. Users should upgrade to 1.19.1 or later.
Affected products
- Apache Software Foundation Apache Tika: from 0.1 through 1.19
References
- http://www.securityfocus.com/bid/105585
- https://access.redhat.com/errata/RHSA-2019:3892
- https://lists.apache.org/thread.html/88de8350cda9b184888ec294c813c5bd8a2081de8fd3666f8904bc05%40%3Cdev.tika.apache.org%3E
- https://security.netapp.com/advisory/ntap-20190903-0002/
- http://www.securityfocus.com/bid/105585
- https://access.redhat.com/errata/RHSA-2019:3892
- https://lists.apache.org/thread.html/88de8350cda9b184888ec294c813c5bd8a2081de8fd3666f8904bc05%40%3Cdev.tika.apache.org%3E
- https://security.netapp.com/advisory/ntap-20190903-0002/
Get alerted when CVE-2018-11796 or the next vulnerability affects your stack