What’s Vulnerable › Vulnerabilities
CVE-2018-11799
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-19 · updated 2026-06-17
- Weakness: CWE-20
Description
Vulnerability allows a user of Apache Oozie 3.1.3-incubating to 5.0.0 to impersonate other users. The malicious user can construct an XML that results workflows running in other user's name.
Affected products
- Apache Software Foundation Apache Oozie: from 3.1.3 before 5.1.0; 3.1.3-incubating — fixed in 5.1.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Oozie 5.1.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106266
- https://lists.apache.org/thread.html/347e7a8cb86014b7ca37e49eb00b8d088203bdc0bcfb4799f8e5955a%40%3Cuser.oozie.apache.org%3E
- http://www.securityfocus.com/bid/106266
- https://lists.apache.org/thread.html/347e7a8cb86014b7ca37e49eb00b8d088203bdc0bcfb4799f8e5955a%40%3Cuser.oozie.apache.org%3E
Get alerted when CVE-2018-11799 or the next vulnerability affects your stack