What’s Vulnerable › Vulnerabilities
CVE-2018-11802
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-01 · updated 2026-06-17
- Weakness: CWE-863
Description
In Apache Solr, the cluster can be partitioned into multiple collections and only a subset of nodes actually host any given collection. However, if a node receives a request for a collection it does not host, it proxies the request to a relevant node and serves the request. Solr bypasses all authorization settings for such requests. This affects all Solr versions prior to 7.7 that use the default authorization mechanism of Solr (RuleBasedAuthorizationPlugin).
Affected products
- Apache Software Foundation Apache Solr: from 4.2.0 before 6.6.6; from 7.0.0 before 7.7.0 — fixed in 6.6.6, 7.7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Solr 6.6.6, 7.7.0. Check the vendor advisory for mitigations.
References
- https://www.openwall.com/lists/oss-security/2019/04/24/1
- https://www.openwall.com/lists/oss-security/2019/04/24/1
Get alerted when CVE-2018-11802 or the next vulnerability affects your stack