What’s Vulnerable › Vulnerabilities
CVE-2018-1183
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-30 · updated 2026-06-17
- Weakness: CWE-611
Description
In Dell EMC Unisphere for VMAX Virtual Appliance versions prior to 8.4.0.8, Dell EMC Solutions Enabler Virtual Appliance versions prior to 8.4.0.8, Dell EMC VASA Provider Virtual Appliance versions prior to 8.4.0.512, Dell EMC SMIS versions prior to 8.4.0.6, Dell EMC VMAX Embedded Management (eManagement) versions prior to and including 1.4.0.347, Dell EMC VNX2 Operating Environment (OE) for File versions prior to 8.1.9.231, Dell EMC VNX2 Operating Environment (OE) for Block versions prior to 05.33.009.5.231, Dell EMC VNX1 Operating Environment (OE) for File versions prior to 7.1.82.0, Dell EMC VNX1 Operating Environment (OE) for Block versions prior to 05.32.000.5.225, Dell EMC VNXe3200 Operating Environment (OE) all versions, Dell EMC VNXe1600 Operating Environment (OE) versions prior to 3.1.9.9570228, Dell EMC VNXe 3100/3150/3300 Operating Environment (OE) all versions, Dell EMC ViPR SRM versions 3.7, 3.7.1, 3.7.2 (only if using Dell EMC Host Interface for Windows), Dell EMC ViPR SRM versions 4.0, 4.0.1, 4.0.2, 4.0.3 (only if using Dell EMC Host Interface for Windows), Dell EMC XtremIO versions 4.x, Dell EMC VMAX eNAS version 8.x, Dell EMC Unity Operating Environment (OE) versions prior to 4.3.0.1522077968, ECOM is affected by a XXE injection vulnerability due to the configuration of the XML parser shipped with the product. XXE Injection attack may occur when XML input containing a reference to an external entity (defined by the attacker) is processed by an affected XML parser. XXE Injection may allow attackers to gain unauthorized access to files containing sensitive information or may be used to cause denial-of-service.
Affected products
- Dell Emc Smis: before 8.4.0.6 — fixed in 8.4.0.6
- Dell Emc Solutions Enabler Virtual Appliance: before 8.4.0.8 — fixed in 8.4.0.8
- Dell Emc Unisphere: before 8.4.0.8 — fixed in 8.4.0.8
- Dell Emc Unity Operating Environment: before 4.3.0.1522077968 — fixed in 4.3.0.1522077968
- VASA Provider Virtual Appliance versions 8.3.x and prior: before 8.4.0.512 — fixed in 8.4.0.512
- Dell Emc Vipr Srm: 3.7, 3.7.1, 3.7.2, 4.0, 4.0.1, 4.0.2 (+1)
- Dell Emc Vmax Embedded Management: through 1.4.0.347
- Dell Emc Vmax Enas: 8.0, 8.0.1
- Dell Emc Vnx1 Operating Environment: 05.32.000.5.225, 7.1.82.0
- Dell Emc Vnx2 Operating Environment: before 05.33.009.5.231; before 8.1.9.231 — fixed in 05.33.009.5.231, 8.1.9.231
- Dell Emc Vnxe1600 Operating Environment: before 3.1.9.9570228 — fixed in 3.1.9.9570228
- Dell Emc Vnxe3200 Operating Environment: all versions
- Dell Emc Vnxe 3100 Operating Environment: all versions
- Dell Emc Vnxe 3150 Operating Environment: all versions
- Dell Emc Vnxe 3300 Operating Environment: all versions
- Dell Emc Xtremio: 4.0, 4.0.2
How to fix
Upgrade to a fixed version: Dell Emc Smis 8.4.0.6; Dell Emc Solutions Enabler Virtual Appliance 8.4.0.8; Dell Emc Unisphere 8.4.0.8; Dell Emc Unity Operating Environment 4.3.0.1522077968; VASA Provider Virtual Appliance versions 8.3.x and prior 8.4.0.512; Dell Emc Vnx2 Operating Environment 05.33.009.5.231, 8.1.9.231; Dell Emc Vnxe1600 Operating Environment 3.1.9.9570228. Check the vendor advisory for mitigations.
References
- http://seclists.org/fulldisclosure/2018/Apr/61
- http://www.securityfocus.com/bid/104024
- http://seclists.org/fulldisclosure/2018/Apr/61
- http://www.securityfocus.com/bid/104024
Get alerted when CVE-2018-1183 or the next vulnerability affects your stack