What’s Vulnerable › Vulnerabilities
CVE-2018-12029
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-17 · updated 2026-06-17
- Weakness: CWE-362
Description
A race condition in the nginx module in Phusion Passenger 3.x through 5.x before 5.3.2 allows local escalation of privileges when a non-standard passenger_instance_registry_dir with insufficiently strict permissions is configured. Replacing a file with a symlink after the file was created, but before it was chowned, leads to the target of the link being chowned via the path. Targeting sensitive files such as root's crontab file allows privilege escalation.
Affected products
- Debian Linux: 8.0
- Phusion Passenger: from 3.0.0 before 5.3.2 — fixed in 5.3.2
How to fix
Upgrade to a fixed version: Phusion Passenger 5.3.2. Check the vendor advisory for mitigations.
References
- https://blog.phusion.nl/passenger-5-3-2
- https://lists.debian.org/debian-lts-announce/2018/06/msg00007.html
- https://pulsesecurity.co.nz/advisories/phusion-passenger-priv-esc
- https://security.gentoo.org/glsa/201807-02
- https://blog.phusion.nl/passenger-5-3-2
- https://lists.debian.org/debian-lts-announce/2018/06/msg00007.html
- https://pulsesecurity.co.nz/advisories/phusion-passenger-priv-esc
- https://security.gentoo.org/glsa/201807-02
Get alerted when CVE-2018-12029 or the next vulnerability affects your stack