What’s Vulnerable › Vulnerabilities
CVE-2018-12036
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-07 · updated 2026-06-17
- Weakness: CWE-22
Description
OWASP Dependency-Check before 3.2.0 allows attackers to write to arbitrary files via a crafted archive that holds directory traversal filenames.
Affected products
- OWASP Dependency-Check: before 3.2.0 — fixed in 3.2.0
How to fix
Upgrade to a fixed version: OWASP Dependency-Check 3.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/jeremylong/DependencyCheck/blob/master/RELEASE_NOTES.md#version-320-2018-05-21
- https://github.com/snyk/zip-slip-vulnerability
- https://github.com/jeremylong/DependencyCheck/blob/master/RELEASE_NOTES.md#version-320-2018-05-21
- https://github.com/snyk/zip-slip-vulnerability
Get alerted when CVE-2018-12036 or the next vulnerability affects your stack