What’s Vulnerable › Vulnerabilities
CVE-2018-12071
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-17 · updated 2026-06-17
- Weakness: CWE-384
Description
A Session Fixation issue exists in CodeIgniter before 3.1.9 because session.use_strict_mode in the Session Library was mishandled.
Affected products
- CodeIgniter4: before 3.1.9 — fixed in 3.1.9
How to fix
Upgrade to a fixed version: CodeIgniter4 3.1.9. Check the vendor advisory for mitigations.
References
- https://github.com/bcit-ci/CodeIgniter/commit/800a20d6c4662d99ae0988b2f8f2238bb8bb29db
- https://www.codeigniter.com/user_guide/changelog.html
- https://www.codeigniter.com/user_guide/changelog.html
Get alerted when CVE-2018-12071 or the next vulnerability affects your stack