What’s Vulnerable › Vulnerabilities
CVE-2018-12115
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-21 · updated 2026-10-15
- Weakness: CWE-787
Description
In all versions of Node.js prior to 6.14.4, 8.11.4 and 10.9.0 when used with UCS-2 encoding (recognized by Node.js under the names `'ucs2'`, `'ucs-2'`, `'utf16le'` and `'utf-16le'`), `Buffer#write()` can be abused to write outside of the bounds of a single `Buffer`. Writes that start from the second-to-last position of a buffer cause a miscalculation of the maximum length of the input bytes to be written.
Affected products
- Node.js: before 6.14.4; from 8.0.0 before 8.11.4; from 10.0.0 before 10.9.0 — fixed in 10.9.0, 6.14.4, 8.11.4
- Red Hat OpenShift Container Platform 4.18: 3.11
How to fix
Upgrade to a fixed version: Node.js 10.9.0, 6.14.4, 8.11.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105127
- https://access.redhat.com/errata/RHSA-2018:2552
- https://access.redhat.com/errata/RHSA-2018:2553
- https://access.redhat.com/errata/RHSA-2018:2944
- https://access.redhat.com/errata/RHSA-2018:2949
- https://access.redhat.com/errata/RHSA-2018:3537
- https://nodejs.org/en/blog/vulnerability/august-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
- http://www.securityfocus.com/bid/105127
- https://access.redhat.com/errata/RHSA-2018:2552
- https://access.redhat.com/errata/RHSA-2018:2553
- https://access.redhat.com/errata/RHSA-2018:2944
Get alerted when CVE-2018-12115 or the next vulnerability affects your stack