What’s Vulnerable › Vulnerabilities
CVE-2018-12116
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-11-28 · updated 2026-10-08
- Weakness: CWE-115
Description
Node.js: All versions prior to Node.js 6.15.0 and 8.14.0: HTTP request splitting: If Node.js can be convinced to use unsanitized user-provided Unicode data for the `path` option of an HTTP request, then data can be provided which will trigger a second, unexpected, and user-defined HTTP request to made to the same server.
Affected products
- Node.js: from 6.0.0 through 6.8.1; from 6.9.0 before 6.15.0; from 8.0.0 through 8.8.1; from 8.9.0 before 8.14.0 — fixed in 6.15.0, 8.14.0
- Suse Enterprise Storage: 4
- SUSE Linux Enterprise: 12, 15
- Suse Openstack Cloud: 7, 8
How to fix
Upgrade to a fixed version: Node.js 6.15.0, 8.14.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:1821
- https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
- https://access.redhat.com/errata/RHSA-2019:1821
- https://nodejs.org/en/blog/vulnerability/november-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
Get alerted when CVE-2018-12116 or the next vulnerability affects your stack