What’s Vulnerable › Vulnerabilities
CVE-2018-1212: Authenticated remote code execution in iDRAC 6
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-02 · updated 2026-06-17
- Weakness: CWE-77
Description
The web-based diagnostics console in Dell EMC iDRAC6 (Monolithic versions prior to 2.91 and Modular all versions) contains a command injection vulnerability. A remote authenticated malicious iDRAC user with access to the diagnostics console could potentially exploit this vulnerability to execute arbitrary commands as root on the affected iDRAC system.
Affected products
- Dell EMC iDRAC6 (Modular): all versions
- Dell EMC iDRAC6 (Monolithic): before 2.91 — fixed in 2.91
How to fix
Upgrade to a fixed version: Dell EMC iDRAC6 (Monolithic) 2.91. Check the vendor advisory for mitigations.
References
- http://en.community.dell.com/techcenter/extras/m/white_papers/20487494
- http://en.community.dell.com/techcenter/extras/m/white_papers/20487494
Get alerted when CVE-2018-1212 or the next vulnerability affects your stack