What’s Vulnerable › Vulnerabilities

CVE-2018-12122

Description

Node.js: All versions prior to Node.js 6.15.0, 8.14.0, 10.14.0 and 11.3.0: Slowloris HTTP Denial of Service: An attacker can cause a Denial of Service (DoS) by sending headers very slowly keeping HTTP or HTTPS connections and associated resources alive for a long period of time.

Affected products

How to fix

Upgrade to a fixed version: Node.js 10.14.0, 11.3.0, 6.15.1, 8.14.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-12122 or the next vulnerability affects your stack