What’s Vulnerable › Vulnerabilities
CVE-2018-12147
- Severity: medium (CVSS 6.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-13 · updated 2026-06-17
- Weakness: CWE-20
Description
Insufficient input validation in HECI subsystem in Intel(R) CSME before version 11.21.55, Intel® Server Platform Services before version 4.0 and Intel® Trusted Execution Engine Firmware before version 3.1.55 may allow a privileged user to potentially enable escalation of privileges via local access.
Affected products
- Intel Corporation Intel(R) CSME, Server Platform Services, Trusted Execution Engine and Intel(R) Active Management Techn: from 11.0 through 11.8.50; from 11.10 through 11.11.50; from 11.20 through 11.21.51
- Intel Corporation Server Platform Services: before 4.0 — fixed in 4.0
- Intel Corporation Trusted Execution Engine: from 3.0 through 3.1.50
How to fix
Upgrade to a fixed version: Intel Corporation Server Platform Services 4.0. Check the vendor advisory for mitigations.
References
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00125.html
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00125.html?wapkw=2018-12147
- https://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00125.html
Get alerted when CVE-2018-12147 or the next vulnerability affects your stack