What’s Vulnerable › Vulnerabilities
CVE-2018-1221
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-19 · updated 2026-06-17
- Weakness: CWE-20
Description
In cf-deployment before 1.14.0 and routing-release before 0.172.0, the Cloud Foundry Gorouter mishandles WebSocket requests for AWS Application Load Balancers (ALBs) and some other HTTP-aware Load Balancers. A user with developer privileges could use this vulnerability to steal data or cause denial of service.
Affected products
- Cloud Foundry cf-deployment: before 1.14.0 — fixed in 1.14.0
- Cloudfoundry Routing-Release: before 0.172.0 — fixed in 0.172.0
How to fix
Upgrade to a fixed version: Cloud Foundry cf-deployment 1.14.0; Cloudfoundry Routing-Release 0.172.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1221 or the next vulnerability affects your stack