What’s Vulnerable › Vulnerabilities
CVE-2018-12256
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-16 · updated 2026-06-17
- Weakness: CWE-434
Description
admin/vqmods.app/vqmods.inc.php in LiteCart before 2.1.3 allows remote authenticated attackers to upload a malicious file (resulting in remote code execution) by using the text/xml or application/xml Content-Type in a public_html/admin/?app=vqmods&doc=vqmods request.
Affected products
- LiteCart: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: LiteCart 2.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/litecart/litecart/commit/2305368eb70a26cab34c772c9ae88787f4c3e669
- https://www.litecart.net/download
- https://github.com/litecart/litecart/commit/2305368eb70a26cab34c772c9ae88787f4c3e669
- https://www.litecart.net/download
Get alerted when CVE-2018-12256 or the next vulnerability affects your stack