What’s Vulnerable › Vulnerabilities
CVE-2018-1231
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-732
Description
Cloud Foundry BOSH CLI, versions prior to v3.0.1, contains an improper access control vulnerability. A user with access to an instance using the BOSH CLI can access the BOSH CLI configuration file and use its contents to perform authenticated requests to BOSH.
Affected products
- Pivotal Software Bosh Cli: before 3.0.1 — fixed in 3.0.1
How to fix
Upgrade to a fixed version: Pivotal Software Bosh Cli 3.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1231 or the next vulnerability affects your stack