What’s Vulnerable › Vulnerabilities
CVE-2018-12356
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-15 · updated 2026-06-17
- Weakness: CWE-347
Description
An issue was discovered in password-store.sh in pass in Simple Password Store 1.7.x before 1.7.2. The signature verification routine parses the output of GnuPG with an incomplete regular expression, which allows remote attackers to spoof file signatures on configuration files and extension scripts. Modifying the configuration file allows the attacker to inject additional encryption keys under their control, thereby disclosing passwords to the attacker. Modifying the extension scripts allows the attacker arbitrary code execution.
Affected products
- Simple Password Store Project Simple Password Store: from 1.7.0 before 1.7.2 — fixed in 1.7.2
How to fix
Upgrade to a fixed version: Simple Password Store Project Simple Password Store 1.7.2. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2018/06/14/3
- http://packetstormsecurity.com/files/152703/Johnny-You-Are-Fired.html
- http://seclists.org/fulldisclosure/2019/Apr/38
- http://www.openwall.com/lists/oss-security/2019/04/30/4
- https://git.zx2c4.com/password-store/commit/?id=8683403b77f59c56fcb1f05c61ab33b9fd61a30d
- https://github.com/RUB-NDS/Johnny-You-Are-Fired
- https://github.com/RUB-NDS/Johnny-You-Are-Fired/blob/master/paper/johnny-fired.pdf
- https://lists.zx2c4.com/pipermail/password-store/2018-June/003308.html
- http://openwall.com/lists/oss-security/2018/06/14/3
- http://packetstormsecurity.com/files/152703/Johnny-You-Are-Fired.html
- http://seclists.org/fulldisclosure/2019/Apr/38
- http://www.openwall.com/lists/oss-security/2019/04/30/4
Get alerted when CVE-2018-12356 or the next vulnerability affects your stack