What’s Vulnerable › Vulnerabilities
CVE-2018-12359
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-119
Description
A buffer overflow can occur when rendering canvas content while adjusting the height and width of the canvas element dynamically, causing data to be written outside of the currently computed boundaries. This results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60, Thunderbird < 52.9, Firefox ESR < 60.1, Firefox ESR < 52.9, and Firefox < 61.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 61.0 — fixed in 61.0
- Mozilla Firefox ESR: before 52.9; from 53.0 before 60.1 — fixed in 52.9, 60.1
- Mozilla Thunderbird: before 52.9; 52.9.1 — fixed in 52.9
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 61.0; Mozilla Firefox ESR 52.9, 60.1; Mozilla Thunderbird 52.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104555
- http://www.securitytracker.com/id/1041193
- https://access.redhat.com/errata/RHSA-2018:2112
- https://access.redhat.com/errata/RHSA-2018:2113
- https://access.redhat.com/errata/RHSA-2018:2251
- https://access.redhat.com/errata/RHSA-2018:2252
- https://bugzilla.mozilla.org/show_bug.cgi?id=1459162
- https://lists.debian.org/debian-lts-announce/2018/06/msg00014.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00013.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3705-1/
Get alerted when CVE-2018-12359 or the next vulnerability affects your stack