What’s Vulnerable › Vulnerabilities
CVE-2018-12361
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow can occur in the SwizzleData code while calculating buffer sizes. The overflowed value is used for subsequent graphics computations when their inputs are not sanitized which results in a potentially exploitable crash. This vulnerability affects Thunderbird < 60, Firefox ESR < 60.1, and Firefox < 61.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 61.0 — fixed in 61.0
- Mozilla Firefox ESR: before 60.1 — fixed in 60.1
- Mozilla Thunderbird: before 60.0 — fixed in 60.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 61.0; Mozilla Firefox ESR 60.1; Mozilla Thunderbird 60.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104558
- http://www.securitytracker.com/id/1041193
- https://bugzilla.mozilla.org/show_bug.cgi?id=1463244
- https://lists.debian.org/debian-lts-announce/2018/11/msg00011.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3705-1/
- https://www.debian.org/security/2018/dsa-4295
- https://www.mozilla.org/security/advisories/mfsa2018-15/
- https://www.mozilla.org/security/advisories/mfsa2018-16/
- https://www.mozilla.org/security/advisories/mfsa2018-19/
- http://www.securityfocus.com/bid/104558
Get alerted when CVE-2018-12361 or the next vulnerability affects your stack