What’s Vulnerable › Vulnerabilities
CVE-2018-12369
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-863
Description
WebExtensions bundled with embedded experiments were not correctly checked for proper authorization. This allowed a malicious WebExtension to gain full browser permissions. This vulnerability affects Firefox ESR < 60.1 and Firefox < 61.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Mozilla Firefox: before 60.1.0; before 61.0 — fixed in 60.1.0, 61.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.1.0, 61.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104561
- http://www.securitytracker.com/id/1041193
- https://bugzilla.mozilla.org/show_bug.cgi?id=1454909
- https://security.gentoo.org/glsa/201810-01
- https://usn.ubuntu.com/3705-1/
- https://www.mozilla.org/security/advisories/mfsa2018-15/
- https://www.mozilla.org/security/advisories/mfsa2018-16/
- http://www.securityfocus.com/bid/104561
- http://www.securitytracker.com/id/1041193
- https://bugzilla.mozilla.org/show_bug.cgi?id=1454909
- https://security.gentoo.org/glsa/201810-01
- https://usn.ubuntu.com/3705-1/
Get alerted when CVE-2018-12369 or the next vulnerability affects your stack