What’s Vulnerable › Vulnerabilities
CVE-2018-1238
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-78
Description
Dell EMC ScaleIO versions prior to 2.5, contain a command injection vulnerability in the Light Installation Agent (LIA). This component is used for central management of ScaleIO deployment and uses shell commands for certain actions. A remote malicious user, with network access to LIA and knowledge of the LIA administrative password, could potentially exploit this vulnerability to run arbitrary commands as root on the systems where LIAs are installed.
Affected products
- Dell EMC ScaleIO: before 2.5 — fixed in 2.5
How to fix
Upgrade to a fixed version: Dell EMC ScaleIO 2.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1238 or the next vulnerability affects your stack