What’s Vulnerable › Vulnerabilities
CVE-2018-12385
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-18 · updated 2026-06-17
- Weakness: CWE-20
Description
A potentially exploitable crash in TransportSecurityInfo used for SSL can be triggered by data stored in the local cache in the user profile directory. This issue is only exploitable in combination with another vulnerability allowing an attacker to write data into the local cache or from locally installed malware. This issue also triggers a non-exploitable startup crash for users switching between the Nightly and Release versions of Firefox if the same profile is used. This vulnerability affects Thunderbird < 60.2.1, Firefox ESR < 60.2.1, and Firefox < 62.0.2.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 62.0.2 — fixed in 62.0.2
- Mozilla Firefox ESR: before 60.2.1 — fixed in 60.2.1
- Mozilla Thunderbird: before 60.2.1 — fixed in 60.2.1
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 62.0.2; Mozilla Firefox ESR 60.2.1; Mozilla Thunderbird 60.2.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105380
- http://www.securitytracker.com/id/1041700
- http://www.securitytracker.com/id/1041701
- https://access.redhat.com/errata/RHSA-2018:2834
- https://access.redhat.com/errata/RHSA-2018:2835
- https://access.redhat.com/errata/RHSA-2018:3403
- https://access.redhat.com/errata/RHSA-2018:3458
- https://bugzilla.mozilla.org/show_bug.cgi?id=1490585
- https://lists.debian.org/debian-lts-announce/2018/11/msg00011.html
- https://security.gentoo.org/glsa/201810-01
- https://security.gentoo.org/glsa/201811-13
- https://usn.ubuntu.com/3778-1/
Get alerted when CVE-2018-12385 or the next vulnerability affects your stack