What’s Vulnerable › Vulnerabilities
CVE-2018-12392
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
Description
When manipulating user events in nested loops while opening a document through script, it is possible to trigger a potentially exploitable crash due to poor event handling. This vulnerability affects Firefox < 63, Firefox ESR < 60.3, and Thunderbird < 60.3.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 60.3.0; before 63.0 — fixed in 60.3.0, 63.0
- Mozilla Thunderbird: before 60.3.0 — fixed in 60.3.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 60.3.0, 63.0; Mozilla Thunderbird 60.3.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105718
- http://www.securityfocus.com/bid/105769
- http://www.securitytracker.com/id/1041944
- https://access.redhat.com/errata/RHSA-2018:3005
- https://access.redhat.com/errata/RHSA-2018:3006
- https://access.redhat.com/errata/RHSA-2018:3531
- https://access.redhat.com/errata/RHSA-2018:3532
- https://bugzilla.mozilla.org/show_bug.cgi?id=1492823
- https://lists.debian.org/debian-lts-announce/2018/11/msg00008.html
- https://lists.debian.org/debian-lts-announce/2018/11/msg00011.html
- https://security.gentoo.org/glsa/201811-04
- https://security.gentoo.org/glsa/201811-13
Get alerted when CVE-2018-12392 or the next vulnerability affects your stack