What’s Vulnerable › Vulnerabilities
CVE-2018-12395
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
Description
By rewriting the Host: request headers using the webRequest API, a WebExtension can bypass domain restrictions through domain fronting. This would allow access to domains that share a host that are otherwise restricted. This vulnerability affects Firefox ESR < 60.3 and Firefox < 63.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Mozilla Firefox: before 63.0 — fixed in 63.0
- Mozilla Firefox ESR: before 60.3 — fixed in 60.3
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Eus: 7.5
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 63.0; Mozilla Firefox ESR 60.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105718
- http://www.securitytracker.com/id/1041944
- https://access.redhat.com/errata/RHSA-2018:3005
- https://access.redhat.com/errata/RHSA-2018:3006
- https://bugzilla.mozilla.org/show_bug.cgi?id=1467523
- https://lists.debian.org/debian-lts-announce/2018/11/msg00008.html
- https://security.gentoo.org/glsa/201811-04
- https://usn.ubuntu.com/3801-1/
- https://www.debian.org/security/2018/dsa-4324
- https://www.mozilla.org/security/advisories/mfsa2018-26/
- https://www.mozilla.org/security/advisories/mfsa2018-27/
- http://www.securityfocus.com/bid/105718
Get alerted when CVE-2018-12395 or the next vulnerability affects your stack