What’s Vulnerable › Vulnerabilities
CVE-2018-1240
- Severity: high (CVSS 8.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-18 · updated 2026-06-17
- Weakness: CWE-200
Description
Dell EMC ViPR Controller, versions after 3.0.0.38, contain an information exposure vulnerability in the VRRP. VRRP defaults to an insecure configuration in Linux's keepalived component which sends the cluster password in plaintext through multicast. A malicious user, having access to the vCloud subnet where ViPR is deployed, could potentially sniff the password and use it to take over the cluster's virtual IP and cause a denial of service on that ViPR Controller system.
Affected products
- Dell EMC ViPR Controller: from 3.0.0.39 before 3.6.1.4 — fixed in 3.6.1.4
How to fix
Upgrade to a fixed version: Dell EMC ViPR Controller 3.6.1.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1240 or the next vulnerability affects your stack