What’s Vulnerable › Vulnerabilities
CVE-2018-12401
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Some special resource URIs will cause a non-exploitable crash if loaded with optional parameters following a '?' in the parsed string. This could lead to denial of service (DOS) attacks. This vulnerability affects Firefox < 63.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Mozilla Firefox: before 63.0 — fixed in 63.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 63.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105721
- http://www.securitytracker.com/id/1041944
- https://bugzilla.mozilla.org/show_bug.cgi?id=1422456
- https://usn.ubuntu.com/3801-1/
- https://www.mozilla.org/security/advisories/mfsa2018-26/
- http://www.securityfocus.com/bid/105721
- http://www.securitytracker.com/id/1041944
- https://bugzilla.mozilla.org/show_bug.cgi?id=1422456
- https://usn.ubuntu.com/3801-1/
- https://www.mozilla.org/security/advisories/mfsa2018-26/
Get alerted when CVE-2018-12401 or the next vulnerability affects your stack