What’s Vulnerable › Vulnerabilities
CVE-2018-12407
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
- Weakness: CWE-119
Description
A buffer overflow occurs when drawing and validating elements with the ANGLE graphics library, used for WebGL content, when working with the VertexBuffer11 module. This results in a potentially exploitable crash. This vulnerability affects Firefox < 64.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Mozilla Firefox: before 64.0 — fixed in 64.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 64.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106167
- https://bugzilla.mozilla.org/show_bug.cgi?id=1505973
- https://usn.ubuntu.com/3844-1/
- https://www.mozilla.org/security/advisories/mfsa2018-29/
- http://www.securityfocus.com/bid/106167
- https://bugzilla.mozilla.org/show_bug.cgi?id=1505973
- https://usn.ubuntu.com/3844-1/
- https://www.mozilla.org/security/advisories/mfsa2018-29/
Get alerted when CVE-2018-12407 or the next vulnerability affects your stack