What’s Vulnerable › Vulnerabilities
CVE-2018-12418
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-14 · updated 2026-06-17
- Weakness: CWE-835
Description
Archive.java in Junrar before 1.0.1, as used in Apache Tika and other products, is affected by a denial of service vulnerability due to an infinite loop when handling corrupt RAR files.
Affected products
- junrar: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: junrar 1.0.1. Check the vendor advisory for mitigations.
References
- https://github.com/junrar/junrar/commit/ad8d0ba8e155630da8a1215cee3f253e0af45817
- https://github.com/junrar/junrar/pull/8
- https://github.com/junrar/junrar/commit/ad8d0ba8e155630da8a1215cee3f253e0af45817
- https://github.com/junrar/junrar/pull/8
Get alerted when CVE-2018-12418 or the next vulnerability affects your stack