What’s Vulnerable › Vulnerabilities
CVE-2018-12423
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-14 · updated 2026-06-17
Description
In Synapse before 0.31.2, unauthorised users can hijack rooms when there is no m.room.power_levels event in force.
Affected products
- matrix-org synapse: before 0.31.2 — fixed in 0.31.2
How to fix
Upgrade to a fixed version: matrix-org synapse 0.31.2. Check the vendor advisory for mitigations.
References
- https://bugs.debian.org/901549
- https://github.com/matrix-org/matrix-doc/issues/1304
- https://matrix.org/blog/2018/06/14/security-update-synapse-0-31-2/
- https://bugs.debian.org/901549
- https://github.com/matrix-org/matrix-doc/issues/1304
- https://matrix.org/blog/2018/06/14/security-update-synapse-0-31-2/
Get alerted when CVE-2018-12423 or the next vulnerability affects your stack