What’s Vulnerable › Vulnerabilities
CVE-2018-1244: iDRAC7/iDRAC8/iDrac9 contains a command injection vulnerability in the SNMP agent.
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-02 · updated 2026-06-17
- Weakness: CWE-77
Description
Dell EMC iDRAC7/iDRAC8, versions prior to 2.60.60.60, and iDRAC9 versions prior to 3.21.21.21 contain a command injection vulnerability in the SNMP agent. A remote authenticated malicious iDRAC user with configuration privileges could potentially exploit this vulnerability to execute arbitrary commands on the iDRAC where SNMP alerting is enabled.
Affected products
- Dell Idrac7 Firmware: before 2.60.60.60 — fixed in 2.60.60.60
- Dell Idrac8 Firmware: before 2.60.60.60 — fixed in 2.60.60.60
- Dell EMC iDRAC: before 3.21.21.21 — fixed in 3.21.21.21
How to fix
Upgrade to a fixed version: Dell Idrac7 Firmware 2.60.60.60; Dell Idrac8 Firmware 2.60.60.60; Dell EMC iDRAC 3.21.21.21. Check the vendor advisory for mitigations.
References
- http://en.community.dell.com/techcenter/extras/m/white_papers/20487494
- http://www.securityfocus.com/bid/104964
- http://en.community.dell.com/techcenter/extras/m/white_papers/20487494
- http://www.securityfocus.com/bid/104964
Get alerted when CVE-2018-1244 or the next vulnerability affects your stack