What’s Vulnerable › Vulnerabilities
CVE-2018-12457
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-15 · updated 2026-06-17
- Weakness: CWE-732
Description
expressCart before 1.1.6 allows remote attackers to create an admin user via a /admin/setup Referer header.
Affected products
- Expresscart Project Expresscart: before 1.1.6 — fixed in 1.1.6
How to fix
Upgrade to a fixed version: Expresscart Project Expresscart 1.1.6. Check the vendor advisory for mitigations.
References
- https://github.com/mrvautin/expressCart/commit/baccaae9b0b72f00b10c5453ca00231340ad3e3b
- https://hackerone.com/reports/343626
- https://www.npmjs.com/package/express-cart?activeTab=versions
- https://github.com/mrvautin/expressCart/commit/baccaae9b0b72f00b10c5453ca00231340ad3e3b
- https://hackerone.com/reports/343626
- https://www.npmjs.com/package/express-cart?activeTab=versions
Get alerted when CVE-2018-12457 or the next vulnerability affects your stack