What’s Vulnerable › Vulnerabilities
CVE-2018-12564
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-19 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in Linaro LAVA before 2018.5.post1. Because of support for URLs in the submit page, a user can forge an HTTP request that will force lava-server-gunicorn to return any file on the server that is readable by lavaserver and valid yaml.
Affected products
- Debian Linux: 8.0, 9.0
- Linaro Lava: before 2018.5.post1 — fixed in 2018.5.post1
How to fix
Upgrade to a fixed version: Linaro Lava 2018.5.post1. Check the vendor advisory for mitigations.
References
- https://git.linaro.org/lava/lava.git/commit/?id=95a9a77b144ced24d7425d6544ab03ca7f6c75d3
- https://lists.debian.org/debian-lts-announce/2018/06/msg00011.html
- https://www.debian.org/security/2018/dsa-4234
- https://git.linaro.org/lava/lava.git/commit/?id=95a9a77b144ced24d7425d6544ab03ca7f6c75d3
- https://lists.debian.org/debian-lts-announce/2018/06/msg00011.html
- https://www.debian.org/security/2018/dsa-4234
Get alerted when CVE-2018-12564 or the next vulnerability affects your stack