What’s Vulnerable › Vulnerabilities
CVE-2018-12581
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-21 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in js/designer/move.js in phpMyAdmin before 4.8.2. A Cross-Site Scripting vulnerability has been found where an attacker can use a crafted database name to trigger an XSS attack when that database is referenced from the Designer feature.
Affected products
- phpMyAdmin: before 4.8.2 — fixed in 4.8.2
How to fix
Upgrade to a fixed version: phpMyAdmin 4.8.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104530
- http://www.securitytracker.com/id/1041187
- https://www.phpmyadmin.net/security/PMASA-2018-3/
- http://www.securityfocus.com/bid/104530
- http://www.securitytracker.com/id/1041187
- https://www.phpmyadmin.net/security/PMASA-2018-3/
Get alerted when CVE-2018-12581 or the next vulnerability affects your stack