What’s Vulnerable › Vulnerabilities
CVE-2018-12605
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in GitLab Community Edition and Enterprise Edition 10.7.x before 10.7.6. The usage of 'url_for' contained a XSS issue due to it allowing arbitrary protocols as a parameter.
Affected products
- GitLab: from 10.7.0 before 10.7.6 — fixed in 10.7.6
How to fix
Upgrade to a fixed version: GitLab 10.7.6. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/06/25/security-release-gitlab-11-dot-0-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/45168
- https://about.gitlab.com/2018/06/25/security-release-gitlab-11-dot-0-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/45168
Get alerted when CVE-2018-12605 or the next vulnerability affects your stack