What’s Vulnerable › Vulnerabilities
CVE-2018-12606
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue was discovered in GitLab Community Edition and Enterprise Edition before 10.7.6, 10.8.x before 10.8.5, and 11.x before 11.0.1. The wiki contains a persistent XSS issue due to a lack of output encoding affecting a specific markdown feature.
Affected products
- GitLab: before 10.7.6; from 10.8.0 before 10.8.5; from 11.0.0 before 11.0.1 — fixed in 10.7.6, 10.8.5, 11.0.1
How to fix
Upgrade to a fixed version: GitLab 10.7.6, 10.8.5, 11.0.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2018/06/25/security-release-gitlab-11-dot-0-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/46957
- https://about.gitlab.com/2018/06/25/security-release-gitlab-11-dot-0-dot-1-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/46957
Get alerted when CVE-2018-12606 or the next vulnerability affects your stack