What’s Vulnerable › Vulnerabilities
CVE-2018-12608
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-10 · updated 2026-06-17
- Weakness: CWE-295
Description
An issue was discovered in Docker Moby before 17.06.0. The Docker engine validated a client TLS certificate using both the configured client CA root certificate and all system roots on non-Windows systems. This allowed a client with any domain validated certificate signed by a system-trusted root CA (as opposed to one signed by the configured CA root certificate) to authenticate.
Affected products
- Docker Engine: before 17.06.0 — fixed in 17.06.0
How to fix
Upgrade to a fixed version: Docker Engine 17.06.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-12608 or the next vulnerability affects your stack