What’s Vulnerable › Vulnerabilities
CVE-2018-12613
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 98.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-21 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can include (view and potentially execute) files on the server. The vulnerability comes from a portion of code where pages are redirected and loaded within phpMyAdmin, and an improper test for whitelisted pages. An attacker must be authenticated, except in the "$cfg['AllowArbitraryServer'] = true" case (where an attacker can specify any host he/she is already in control of, and execute arbitrary code on phpMyAdmin) and the "$cfg['ServerDefault'] = 0" case (which bypasses the login requirement and runs the vulnerable code without any authentication).
Affected products
- phpMyAdmin: from 4.8.0 before 4.8.2 — fixed in 4.8.2
How to fix
Upgrade to a fixed version: phpMyAdmin 4.8.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/164623/phpMyAdmin-4.8.1-Remote-Code-Execution.html
- http://www.securityfocus.com/bid/104532
- https://security.gentoo.org/glsa/201904-16
- https://www.exploit-db.com/exploits/44924/
- https://www.exploit-db.com/exploits/44928/
- https://www.exploit-db.com/exploits/45020/
- https://www.phpmyadmin.net/security/PMASA-2018-4/
- http://packetstormsecurity.com/files/164623/phpMyAdmin-4.8.1-Remote-Code-Execution.html
- http://www.securityfocus.com/bid/104532
- https://security.gentoo.org/glsa/201904-16
- https://www.exploit-db.com/exploits/44924/
- https://www.exploit-db.com/exploits/44928/
Get alerted when CVE-2018-12613 or the next vulnerability affects your stack