What’s Vulnerable › Vulnerabilities
CVE-2018-1266
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-22
Description
Cloud Foundry Cloud Controller, versions prior to 1.52.0, contains information disclosure and path traversal vulnerabilities. An authenticated malicious user can predict the location of application blobs and leverage path traversal to create a malicious application that has the ability to overwrite arbitrary files on the Cloud Controller instance.
Affected products
- Cloud Foundry CAPI: before 1.52.0 — fixed in 1.52.0
How to fix
Upgrade to a fixed version: Cloud Foundry CAPI 1.52.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1266 or the next vulnerability affects your stack