What’s Vulnerable › Vulnerabilities
CVE-2018-1267
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-27 · updated 2026-06-17
- Weakness: CWE-732
Description
Cloud Foundry Silk CNI plugin, versions prior to 0.2.0, contains an improper access control vulnerability. If the platform is configured with an application security group (ASG) that overlaps with the Silk overlay network, any applications can reach any other application on the network regardless of the configured routing policies.
Affected products
- Cloudfoundry Silk-Release: before 0.2.0 — fixed in 0.2.0
How to fix
Upgrade to a fixed version: Cloudfoundry Silk-Release 0.2.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-1267 or the next vulnerability affects your stack