What’s Vulnerable › Vulnerabilities
CVE-2018-12678
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-22 · updated 2026-06-17
- Weakness: CWE-918
Description
Portainer before 1.18.0 supports unauthenticated requests to the websocket endpoint with an unvalidated id query parameter for the /websocket/exec endpoint, which allows remote attackers to bypass intended access restrictions or conduct SSRF attacks.
Affected products
- portainer: before 1.18.0 — fixed in 1.18.0
How to fix
Upgrade to a fixed version: portainer 1.18.0. Check the vendor advisory for mitigations.
References
- https://github.com/portainer/portainer/pull/1979
- https://github.com/portainer/portainer/releases/tag/1.18.0
- https://github.com/portainer/portainer/pull/1979
- https://github.com/portainer/portainer/releases/tag/1.18.0
Get alerted when CVE-2018-12678 or the next vulnerability affects your stack