What’s Vulnerable › Vulnerabilities

CVE-2018-1269

Description

Cloud Foundry Loggregator, versions 89.x prior to 89.5 or 96.x prior to 96.1 or 99.x prior to 99.1 or 101.x prior to 101.9 or 102.x prior to 102.2, does not handle errors thrown while constructing certain http requests. A remote authenticated user may construct malicious requests to cause the traffic controller to leave dangling TCP connections, which could cause denial of service.

Affected products

How to fix

Upgrade to a fixed version: Cloud Foundry Loggregator 101.9, 102.2, 89.5, 96.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-1269 or the next vulnerability affects your stack