What’s Vulnerable › Vulnerabilities
CVE-2018-1299
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-06 · updated 2026-06-17
- Weakness: CWE-22
Description
In Apache Allura before 1.8.0, unauthenticated attackers may retrieve arbitrary files through the Allura web application. Some webservers used with Allura, such as Nginx, Apache/mod_wsgi or paster may prevent the attack from succeeding. Others, such as gunicorn do not prevent it and leave Allura vulnerable.
Affected products
- Apache Software Foundation Apache Allura: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Allura 1.8.0. Check the vendor advisory for mitigations.
References
- https://allura.apache.org/posts/2018-allura-1.8.0.html
- https://lists.apache.org/thread.html/b52069073cf3cb0f84c9e1e2b34d411fc163af39e4f3e50712ac8a4d%40%3Cdev.allura.apache.org%3E
- https://allura.apache.org/posts/2018-allura-1.8.0.html
- https://lists.apache.org/thread.html/b52069073cf3cb0f84c9e1e2b34d411fc163af39e4f3e50712ac8a4d%40%3Cdev.allura.apache.org%3E
Get alerted when CVE-2018-1299 or the next vulnerability affects your stack