What’s Vulnerable › Vulnerabilities
CVE-2018-1310
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-502
Description
Apache NiFi JMS Deserialization issue because of ActiveMQ client vulnerability. Malicious JMS content could cause denial of service. See ActiveMQ CVE-2015-5254 announcement for more information. The fix to upgrade the activemq-client library to 5.15.3 was applied on the Apache NiFi 1.6.0 release. Users running a prior 1.x release should upgrade to the appropriate release.
Affected products
- Apache Software Foundation Apache NiFi: before 1.6.0 — fixed in 1.6.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache NiFi 1.6.0. Check the vendor advisory for mitigations.
References
- https://nifi.apache.org/security.html#CVE-2018-1310
- https://nifi.apache.org/security.html#CVE-2018-1310
Get alerted when CVE-2018-1310 or the next vulnerability affects your stack