What’s Vulnerable › Vulnerabilities
CVE-2018-1321
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 17.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-20 · updated 2026-06-17
- Weakness: CWE-20
Description
An administrator with report and template entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can use XSL Transformations (XSLT) to perform malicious operations, including but not limited to file read, file write, and code execution.
Affected products
- Apache Software Foundation Apache Syncope: from 1.2.0 before 1.2.11; from 2.0.0 before 2.0.8; 1.0.0, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8 (+11) — fixed in 1.2.11, 2.0.8
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 1.2.11, 2.0.8. Check the vendor advisory for mitigations.
References
- http://syncope.apache.org/security.html#CVE-2018-1321:_Remote_code_execution_by_administrators_with_report_and_template_entitlements
- http://www.securityfocus.com/bid/103508
- https://www.exploit-db.com/exploits/45400/
- http://syncope.apache.org/security.html#CVE-2018-1321:_Remote_code_execution_by_administrators_with_report_and_template_entitlements
- http://www.securityfocus.com/bid/103508
- https://www.exploit-db.com/exploits/45400/
Get alerted when CVE-2018-1321 or the next vulnerability affects your stack