What’s Vulnerable › Vulnerabilities
CVE-2018-1322
- Severity: medium (CVSS 4.9 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-20 · updated 2026-06-17
- Weakness: CWE-200
Description
An administrator with user search entitlements in Apache Syncope 1.2.x before 1.2.11, 2.0.x before 2.0.8, and unsupported releases 1.0.x and 1.1.x which may be also affected, can recover sensitive security values using the fiql and orderby parameters.
Affected products
- Apache Software Foundation Apache Syncope: from 1.2.0 before 1.2.11; from 2.0.0 before 2.0.8; 1.0.0, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7 (+11) — fixed in 1.2.11, 2.0.8
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Syncope 1.2.11, 2.0.8. Check the vendor advisory for mitigations.
References
- http://syncope.apache.org/security.html#CVE-2018-1322:_Information_disclosure_via_FIQL_and_ORDER_BY_sorting
- http://www.securityfocus.com/bid/103507
- https://www.exploit-db.com/exploits/45400/
- http://syncope.apache.org/security.html#CVE-2018-1322:_Information_disclosure_via_FIQL_and_ORDER_BY_sorting
- http://www.securityfocus.com/bid/103507
- https://www.exploit-db.com/exploits/45400/
Get alerted when CVE-2018-1322 or the next vulnerability affects your stack