What’s Vulnerable › Vulnerabilities
CVE-2018-1328
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Apache Zeppelin prior to 0.8.0 had a stored XSS issue via Note permissions. Issue reported by "Josna Joseph".
Affected products
- Apache Software Foundation Apache Zeppelin: before 0.8.0 — fixed in 0.8.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Zeppelin 0.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2019/04/23/1
- http://www.securityfocus.com/bid/108047
- https://lists.apache.org/thread.html/ff6b995a5a3ba8db4d6b14b4d9dd487e7bf2e3bdd5b375b64a25fd06%40%3Cusers.zeppelin.apache.org%3E
- https://zeppelin.apache.org/releases/zeppelin-release-0.8.0.html
- http://www.openwall.com/lists/oss-security/2019/04/23/1
- http://www.securityfocus.com/bid/108047
- https://lists.apache.org/thread.html/ff6b995a5a3ba8db4d6b14b4d9dd487e7bf2e3bdd5b375b64a25fd06%40%3Cusers.zeppelin.apache.org%3E
- https://zeppelin.apache.org/releases/zeppelin-release-0.8.0.html
Get alerted when CVE-2018-1328 or the next vulnerability affects your stack