What’s Vulnerable › Vulnerabilities
CVE-2018-1335
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 93.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-25 · updated 2026-06-17
Description
From Apache Tika versions 1.7 to 1.17, clients could send carefully crafted headers to tika-server that could be used to inject commands into the command line of the server running tika-server. This vulnerability only affects those running tika-server on a server that is open to untrusted clients. The mitigation is to upgrade to Tika 1.18.
Affected products
- Apache Software Foundation Apache Tika: before 1.18 — fixed in 1.18
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Tika 1.18. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/153864/Apache-Tika-1.17-Header-Command-Injection.html
- http://www.securityfocus.com/bid/104001
- https://access.redhat.com/errata/RHSA-2019:3140
- https://lists.apache.org/thread.html/b3ed4432380af767effd4c6f27665cc7b2686acccbefeb9f55851dca%40%3Cdev.tika.apache.org%3E
- https://www.exploit-db.com/exploits/46540/
- http://packetstormsecurity.com/files/153864/Apache-Tika-1.17-Header-Command-Injection.html
- http://www.securityfocus.com/bid/104001
- https://access.redhat.com/errata/RHSA-2019:3140
- https://lists.apache.org/thread.html/b3ed4432380af767effd4c6f27665cc7b2686acccbefeb9f55851dca%40%3Cdev.tika.apache.org%3E
- https://www.exploit-db.com/exploits/46540/
Get alerted when CVE-2018-1335 or the next vulnerability affects your stack