What’s Vulnerable › Vulnerabilities
CVE-2018-13406
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-06 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow in the uvesafb_setcmap function in drivers/video/fbdev/uvesafb.c in the Linux kernel before 4.17.4 could result in local attackers being able to crash the kernel or potentially elevate privileges because kmalloc_array is not used.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0
- Linux kernel: from 2.6.24 before 3.16.58; from 3.17 before 3.18.114; from 3.19 before 4.4.139; from 4.5 before 4.9.111; from 4.10 before 4.14.53; from 4.15 before 4.17.4 — fixed in 3.16.58, 3.18.114, 4.14.53, 4.17.4, 4.4.139, 4.9.111
How to fix
Upgrade to a fixed version: Linux kernel 3.16.58, 3.18.114, 4.14.53, 4.17.4. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=9f645bcc566a1e9f921bdae7528a01ced5bc3713
- http://www.securityfocus.com/bid/104685
- http://www.securitytracker.com/id/1041355
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.17.4
- https://github.com/torvalds/linux/commit/9f645bcc566a1e9f921bdae7528a01ced5bc3713
- https://lists.debian.org/debian-lts-announce/2019/03/msg00017.html
- https://usn.ubuntu.com/3752-1/
- https://usn.ubuntu.com/3752-2/
- https://usn.ubuntu.com/3752-3/
- https://usn.ubuntu.com/3753-1/
- https://usn.ubuntu.com/3753-2/
- https://usn.ubuntu.com/3754-1/
Get alerted when CVE-2018-13406 or the next vulnerability affects your stack