What’s Vulnerable › Vulnerabilities
CVE-2018-13818
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-10 · updated 2026-06-17
- Weakness: CWE-94
Description
Twig before 2.4.4 allows Server-Side Template Injection (SSTI) via the search search_key parameter. NOTE: the vendor points out that Twig itself is not a web application and states that it is the responsibility of web applications using Twig to properly wrap input to it
Affected products
- twigphp Twig: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: twigphp Twig 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/twigphp/Twig/blob/2.x/CHANGELOG
- https://github.com/twigphp/Twig/commit/eddb97148ad779f27e670e1e3f19fb323aedafeb
- https://github.com/twigphp/Twig/issues/2743
- https://mobile.twitter.com/jameel_nabbo/status/1032593354704515072?s=20
- https://www.exploit-db.com/exploits/44102/
- https://github.com/twigphp/Twig/blob/2.x/CHANGELOG
- https://github.com/twigphp/Twig/commit/eddb97148ad779f27e670e1e3f19fb323aedafeb
- https://github.com/twigphp/Twig/issues/2743
- https://mobile.twitter.com/jameel_nabbo/status/1032593354704515072?s=20
- https://www.exploit-db.com/exploits/44102/
Get alerted when CVE-2018-13818 or the next vulnerability affects your stack