What’s Vulnerable › Vulnerabilities
CVE-2018-14040
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-13 · updated 2026-06-17
- Weakness: CWE-79
Description
In Bootstrap before 4.1.2, XSS is possible in the collapse data-parent attribute.
Affected products
- Debian Linux: 8.0
- Getbootstrap Bootstrap: before 3.4.0; from 4.0.0 before 4.1.2; 4.0.0-alpha, 4.0.0-alpha2, 4.0.0-alpha3, 4.0.0-alpha4, 4.0.0-alpha5, 4.0.0-alpha6 (+3) — fixed in 3.4.0, 4.1.2
How to fix
Upgrade to a fixed version: Getbootstrap Bootstrap 3.4.0, 4.1.2. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/152787/dotCMS-5.1.1-Vulnerable-Dependencies.html
- http://packetstormsecurity.com/files/156743/OctoberCMS-Insecure-Dependencies.html
- http://seclists.org/fulldisclosure/2019/May/10
- http://seclists.org/fulldisclosure/2019/May/11
- http://seclists.org/fulldisclosure/2019/May/13
- https://blog.getbootstrap.com/2018/07/12/bootstrap-4-1-2/
- https://github.com/twbs/bootstrap/issues/26423
- https://github.com/twbs/bootstrap/issues/26625
- https://github.com/twbs/bootstrap/pull/26630
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f%40%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/52e0e6b5df827ee7f1e68f7cc3babe61af3b2160f5d74a85469b7b0e%40%3Cdev.superset.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442%40%3Cdev.drill.apache.org%3E
Get alerted when CVE-2018-14040 or the next vulnerability affects your stack