What’s Vulnerable › Vulnerabilities
CVE-2018-14057
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-17 · updated 2026-06-17
- Weakness: CWE-352
Description
Pimcore before 5.3.0 allows remote attackers to conduct cross-site request forgery (CSRF) attacks by leveraging validation of the X-pimcore-csrf-token anti-CSRF token only in the "Settings > Users / Roles" function.
Affected products
- pimcore/pimcore: before 5.3.0 — fixed in 5.3.0
How to fix
Upgrade to a fixed version: pimcore/pimcore 5.3.0. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html
- http://seclists.org/fulldisclosure/2018/Aug/13
- https://www.exploit-db.com/exploits/45208/
- https://www.sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software/
- http://packetstormsecurity.com/files/148954/Pimcore-5.2.3-CSRF-Cross-Site-Scripting-SQL-Injection.html
- http://seclists.org/fulldisclosure/2018/Aug/13
- https://www.exploit-db.com/exploits/45208/
- https://www.sec-consult.com/en/blog/advisories/sql-injection-xss-csrf-vulnerabilities-in-pimcore-software/
Get alerted when CVE-2018-14057 or the next vulnerability affects your stack